
CS 200 Assignment 3 — Pixel Graphics 
Due Monday June 1st  2020, 11:59 pm 

Readings and Resources 
Texts: Suggested excerpts from Learning Web Design 

Files 
The required files are on Learn in the Week 3 > Files for Assignment: Pixel Graphics. You will need: 

• SantaMaria.png 
• AssignThreeRaw.docx 
• Flowers.xcf 
• Flowers_Before&After.pdf 
• Flowers_Palettes.pdf 

Assignment Objectives 
• To explore the interface of Gimp and critically compare it to other applications used so far in class. 
• To use a pixel graphics program to modify/enhance a photo.  
• To modify dimensions and layers in a pixel graphics program.  

Assignment Strategy 
• Questions 1 through 4 must be done independently. 
• Question 5 may be done independently or with a partner. If you work with a partner, please add 

both of your names, usernames, and student IDs to the file and name the files with 
username1_username2. 

• If you want to do all or part of this assignment using Photoshop on your own machine, you may do 
so. Make sure you’re meeting all the requirements of this assignment, but any .xcf files will now 
be .psd files.  

• If you want to use Photoshop for question 5, you must talk to Barbara about this first to get 
modified instructions and obtain permission to do this. Flowers.psd is also available on Learn if you 
have obtained permission.  
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Your Tasks 
1. (10%) Use Gimp to crop and resize a digital image of your choosing with colour so 

that it is exactly 180 pixels high & 150 pixels wide, with a resolution of 100 dpi, and 
shows just a face, like the example on the right. This image does not need to be 
manipulated, although you are free to do so. (Sharpening and Levels Adjustment are 
both nearly always a good idea.) Save this image in a png file with the name 
username_a3q1.png. 

Make a copy of this file and rescale it by one half so that it is exactly 90 pixels high 
and 75 pixels wide. Convert the reduced image to gray-scale and save it in a jpeg file 
with the name username_a3q1.jpg. 

Hints: 
• In Gimp, use the menu item Image > Mode > Grayscale to 

eliminate color information from an image. (Eliminating 
the color information reduces the file  
size by two thirds. Be sure you understand why.) 
Alternatively, you can do this by using  
Colors > Hue-Saturation, and then reducing saturation  
as much as possible.  

• Use Gimp’s Image > Scale Image... dialog to resize an image 
or to change its “resolution.” 

• In the Scale Image… dialog box, make sure the link is 
connected between the width and height to preserve the 
aspect ratio—Gimp will then automatically compute a new 
width if you change the height, and vice-versa.  

• You will find the Crop Tool helpful if you want to select a specific area with specific dimensions. 
• In the Scale Image… dialog, you can choose from “None”, “Linear”, “Cubic”, and “Sinc” for 

“Interpolation”. This refers to how Gimp builds a new image of your intended dimensions by 
adding or removing pixels. You will usually want to select “Cubic”, as it provides the best quality 
results although it takes a little longer.  
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2. (20%) In the Week 3 > Files for Assignment: Pixel Graphics folder 
on Learn, you will find a png image called SantaMaria.png. Open 
this image in Gimp.  

• SantaMaria.png needs to be corrected: the façade verticals are 
not parallel, as they should be to look like the image to the 
right (this is especially noticeable when looking at the right 
and left sides). The image shown to the right is the corrected 
version of the photograph. 

• Starting from the original photograph each time, investigate 
the different types of transformations available in GImp’s 

Tools > Transform Tools menu, by moving the control handles 
of the frame or grid.  

• Identify the transformation type that corrects the verticals in 
the most efficient way (i.e. the least amount of work the user 
has to do).  

• Then, take a screenshot of the Gimp transform with the frame and control handles visible (ie. so 
that we can see the transformation in progress). Do not take a screenshot of the entire screen, only 
the relevant portion. Note that you take a screenshot by using the key combination shift-

command-3 (X--3). If you want to select a specific area of the screen to take a screenshot of, use 
shift-command-4 (X--4).  (The window shortcut is win+shift+S)  
By default, screenshots are saved on the desktop. 

• Save the snapshot as username_a3q2_TransformName.png where TransformName is replaced by the 
transformation you used. 

3. (20%) In Week 3 > Files for Assignment: Pixel Graphics on Learn, you will find AssignThreeRaw.docx, the 
formatted text for the document you are now reading, but without the graphics. Download the file, 
rename it username_a3q3.docx, and then… 

a) Copy/paste or use Insert > Picture > From File... to insert username_a3q1.jpg from question 1 into the 
document. 

b) Use Word’s Picture Format tab to position your image in username_a3q3.docx where the image is in 
question 1. Note that by default, Word snaps pictures to a grid as you move them, which can make it 
impossible to place the picture exactly where you want it. The settings in Layout > Arrange, or by 
right clicking on the picture and selecting Wrap Text > More Layout Options…, should help you 

change this. You may also want to check Word’s online help for information about this grid, and for 
information about pictures. 

c) Use Word’s Picture Format tab to add a one-point black border to the image. 

d) Use similar steps to insert your snapshot, username_a3q2_TransformName.png into 
username_a3q4.docx. Position it at the place of the corrected photograph in question 2. 

e) Update TransformName in the caption with the transform you used in question 2. 

Note that you don’t need to insert the Scale Image dialog box screenshot. 
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4. (20%) Modifying your own image. 

Part A: 
• See how much you can improve a photo of your choosing (or the photo from question 1) using the 

image transformation tools in Gimp. You must use at least four different transformation/
manipulation tools. These tools can include transform tools, colour tools, or any other tools you 
find useful. One of these tools must involve feathering. (ie. feather a selection and then do 
something to that selection⎯this counts as one of the four required transformation/
manipulations.) 

• Place the original image and its improved version together in a Gimp document named 
username_a3q4.xcf. If they are in separate layers, make sure they are visible together beside each 
other (ie. not directly on top of each other).  

• Label the two “Before” and “After”, respectively, and add a text label containing your name, user 
ID & student ID number.  

• “Sign” this document with your name using at least two visibly distinct brushes in two visibly 
distinct colours. 

Part B: 
• In a separate, short MS Word document named username_a3q4.docx write a brief summary of the 4 

tools you used and how you applied them to your image. If you used more than four tools, you 
only need to write about four of them, but you must write about feathering. You only need a 
sentence or two for each of the tools. 

5. (30%) For this question only, you may work together with a partner. If you do so, only one of you 
should submit an answer for this question, and name the files username1_username2_Flowers.xcf and 
username1_username2_Flowers.png. If you want to attempt the bonus question, it’s recommended to 
read the instructions of both question 5 and the bonus question before beginning, as the bonus 
question can count for question 5 and bonus marks (ie. you don’t have to submit both). 

Consider the images in Flowers_Before&After.pdf (found in Week 3 > Files for Assignment: Pixel Graphics 
on Learn). Your task is to use Gimp’s various selection tools and adjustments to convert the image in 
Flowers.xcf into the “After” image appearing in Flowers_Before&After.pdf. First, you’ll be making the 
relevant selections and saving those selections to channels. Then you’ll be making the relevant 
adjustments and using layers to keep track of these adjustments. 

Saving Selections to Channels  1

Start by making the following selections (check out “Hints” on the next page for some suggestions): 
• Select the petals of the flower (the one that’s coloured in the “After” image) and save that selection 

as a channel named Flower_Petals; 
• Select the yellow centre of that flower and save that selection as a channel called Flower_Centre; 
• Select everything except for these selections and save this as a channel called Background. (Select > 

Invert) should help you with this. 

Think about how feathering the selections could be used to improve the image shown in 
Flowers_Before&After.pdf. Consider feathering your selections.  

 Channels do not have to be exact. Don’t waste time or get frustrated trying to make things exact. 1
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At this point, your Channels palette should look like the channels palette shown in 
Flowers_Palettes.pdf. You should change the channel names to match these too. 

Saving Adjustments as Layers 

Now you’re going to be making adjustments so that your image will match the “After” image. In class, 
we learned that Gimp doesn’t have adjustment layers. To mimic this, before making an adjustment, 
make a copy of the previous layer, and then work from the copy. This will allow you to easily undo 
adjustments if necessary. Create layers as shown on the left of Flowers_Palettes.pdf, starting from the 
bottom, duplicating layers, and making the necessary adjustments. Rename the layers to match those 
in Flowers_Palettes.pdf.  A few notes to help you with this… 

• The first layer you’ll be making is “Levels_Overall”. Start by copying the original layer, and with the 
new layer selected, adjust the levels. In addition to what we learned in class about levels, in this 
case you’ll want to adjust the midpoint of the histogram as well, since most of the pixels in this 
image are concentrated at either end. Think about why this is.  

• Note that ”B&C” refers to Brightness-Contrast. 

• When adjusting Colour Balance of both the centre and the petals, you’ll want to individually adjust 
the shadows, midtones, and highlights. The colours don’t need to be exactly the same in each of 
these ranges, but the combination of all three should match the “After” image as closely as 
possible.  

After making all of these adjustments, your image should look as close to the “After” image as is 
reasonably possible, and your channels and layers should match those shown in Flowers_Palettes.pdf. 
Do not merge your layers or we will not be able to see that you made all the necessary layers, and won’t 
be able to give you full marks. Save this Gimp file as username_a3q5.xcf (or 
username1_username2_a3q5.xcf if you worked with a partner). Save a png of this image as 
username_a3q5.png (or username1_username2_a3q5.png). 

CS 200 Assignment 3  Page 5



Bonus: 
The bonus question is an extension of question 5 where you must modify two flowers instead of one. 
You must modify the flower that’s been modified in question 5, and you can choose any additional 
flower. An example of this is shown in Bonus_Before&After.pdf.  

For full bonus marks, you will also need to match your channels palette to that shown in 
Bonus_Palettes.pdf. This involves saving the following additional selections to channels: 

• The petals of the second flower (you should already have the petals of the first flower saved from 
question 5); 

• The centre of the second flower (you should already have the centre of the first flower saved from 
question 5); 

• You must then combine the two petals selections and save them together as a channel called 
Both_Petals. This allows you to make adjustments on the petals of both flowers simultaneously, 
ensuring they are adjusted in the same way. 

• You must also combine the two centre selections and save them together as a channel called 
Both_Centers. Again, this allows you to make the same adjustments to both centers 
simultaneously, ensuring they’re adjusted in the same way. 

• You must select everything but these selections and save this selection as a channel called 
Background (which is different from the Background channel you would have from question 5). 

After making these selections, you will perform the same adjustments that are described in question 5, 
but any adjustments to the petals or the centre of the flower described in question 5 should be applied 
to both flowers simultaneously so that both flowers receive the exact same adjustments.  

After doing this, the image should look as similar as possible to the “After” image in 
Bonus_Before&After.pdf, and the channels and layers palettes should match those shown in 
Bonus_Palettes.pdf. Do not merge your layers or we will not be able to see that you made all the 
necessary layers, and won’t be able to give you full marks.  

Save the Gimp file as username_a3bonus.xcf (or username1_username2_a3bonus.xcf if you worked with 
a partner). Save a png of this image as username_a3bonus.png (or username1_username2_a3bonus.png).  

If you submit the bonus question, you do not need to submit question 5. Your marks for question 5 
will come from you bonus submission, and any bonus marks will be applied on top of that. 
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Hints about Selections 
• You may find the following selection tools useful: Fuzzy Select Tool, Scissors Select Tool, Free Select 

Tool, Select by Colour Tool. You can add and subtract pixels from these selections by using shift and 
command.  

• Using Fuzzy Select Tool will likely be your easiest option. You can add to your selection by shift 
clicking. It might also be helpful to increase the threshold on Fuzzy Select, so that the pixels don’t 
have to be quite as similar in order to be added to the same selection. 

• It will likely also be helpful to use the Quick Mask (access this via Select > Toggle Quick Mask). Quick 

Mask allows you to use the paint brush and eraser to add and subtract from a selection.  
• You will probably also want to feather your selections by a few pixels to obtain a smooth transition 

from areas affected by an adjustment to areas not affected. You can access feathering by right 
clicking on the selection and selecting Select > Feather… 

Submission Instructions 
Create a folder called username_Assign3, containing the following: 

Question 1:  The large cropped & resized image username_a3q1.png and the smaller grayscale version of 
this file named username_a3q1.jpg. 

Question 2:  Your snapshot of the transformation in action that you identified in question 2, named 
username_a3q2_TransformName.png. 

Question 3:  Your modified copy of AssignThreeRaw, named username_a3q3.docx which contains the two 
images you added. 

Question 4:  The Gimp document username_a2q4.xcf including your before and after photos, and the 
summary of your transformations in username_a3q4.docx. 

Question 5:  The Gimp document, username_a3q5.xcf, where we can see your channels and layers, and the 
file username_a3q5.png created from it (or username1_username2_a3q5.xcf and 
username1_username2_a3q5.png if you have a partner). 

Bonus: The Gimp document, username_a3bonus.xcf, where we can see your channels and layers, and 
the file username_a3bonus.png created from it (or username1_username2_a3bonus.xcf and 
username1_username2_bonus.png if you have a partner). If you submit the bonus question, 
you don’t need to submit question 5, as your marks for question 5 will come from your bonus 
submission, and any bonus marks will be applied on top of that.  

Compress the folder, name it username_Assign3 and submit to the Assignment 3 DropBox on Learn.
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