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Lecture 02

Structured Word Processing — Styles
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https://www.youtube.com/watch?v=dTAAsCNK7RA

This week’s fun video

https://www.youtube.com/watch?v=dTAAsCNK7RA
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Miscellaneous Notes

Assigned reading
• “The Non–Designer’s Design Book,” by Robin Williams (chapters 1-6)
• “Adobe on Basic Typography” (https://www.student.cs.uwaterloo.ca/~cs200/Adobe/

main.html)

Please read and highlight before this week’s lab
• Assignment 2 (due Monday May 25 at 11:59 pm)
• Notes for this lecture

Today and Thursday
• [named] styles
• the Poke pearl
• backups

Don’t forget to download the Microsoft Office Suite.  
You will not be able to do this assignment on the web version of Word.

https://www.student.cs.uwaterloo.ca/~cs200/Adobe/main.html
https://www.student.cs.uwaterloo.ca/~cs200/Adobe/main.html
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Assumptions

You have used a word processor before

You understand and correctly use the following WP tools
• Word Wrap (hard carriage return vs. soft carriage return)
• Cut/Copy and Paste
• Font usage (size, style and typeface)
• Rulers and Margins
• Proper use of tabs
• Headers and footers (page numbering)
• Footnotes
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Things to Think About

• What are the data objects in a Word Processor?
• Is there more than one way to do any given task?
• What are deficiencies of the interface?
• What are efficiencies of the interface?

5



CS 200 Spring 2020 02 – Styles

The idea
• name a collection of paragraph or character attributes
• you then apply the NAME to text instead of individually setting attributes

Hence changing a document’s appearance is
• easier & faster, more accurate (⇒consistency, if used intelligently)

• — you just change the definition of the name; everywhere it’s used, text changes

Does appearance matter? → Yes!
• legibility
• understandability
• professionalism

6

[Named] Styles (1)
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Named Styles (2)

Terminology
• Attributes: Helvetica, Palatino, bold, italic, underlined, red, 15 pt leading, etc. are 

attributes
• [Named Style]: A (named) style is a (specific) “bundle of attributes”
• We usually specify that it is a “named style” for emphasis/clarity

• ex. “Heading” could be a named style with attributes “24 pt Myriad Pro Light with 
12 pts of Before Paragraph leading & 2 cm of left indent”

7
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Compare this and the preceding slide

Terminology Attributes: Helvetica, Palatino, bold, italic, underlined, red, 15 pt leading, etc. 
are attributes [Named Style]: A (named) style is a (specific) “bundle of attributes” We 
usually specify that it is a “named style” for emphasis/clarity ex. “Heading” could be a 
named style with attributes “24 pt Myriad Pro Light with 12 pts of Before Paragraph leading 
& 2 cm of left indent”
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See Word’s Preferences > View dialog

Or, press         from Word’s Home menu

“Invisible” (aka “non-printing”) characters

9
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The text being formatted The style definitions (built-in & user-defined)
Block

Font:(Default) Times, 12 pt, English (US), Justified, Line spacing: single, Space Before: 6 pt, 
Widow/Orphan control 

Block_Centered
Font:(Default) Times, 12 pt, English (US), Centered, Line spacing: single, Widow/Orphan 
control, No bullets or numbering 

Default Paragraph Font 
The font of the underlying paragraph style + 

Emphasis_Slight 
Default Paragraph Font + Font:Italic 

Figure_Caption
Font:(Default) Times, 10 pt, English (US), Indent: Left: 0.39”, Right: 0.39”, Justified, Line 
spacing: exactly 12 pt, Space Before: 6 pt, Widow/Orphan control

Footer
Font:(Default) Times, 10 pt, English (US), Left, Line spacing: single, Widow/Orphan control, 
Tabs: 3.25”, Centered + 6.5”, Right 

Footnote Reference 
Default Paragraph Font + Superscript 

Footnote Text
Font:(Default) Times, 10 pt, English (US), Justified, Line spacing: exactly 10 pt, Space Before: 4 
pt, Widow/Orphan control

 Header
Font:(Default) Times, 10 pt, English (US), Left, Line spacing: single, Widow/Orphan control, 
Tabs: 3.25”, Centered + 6.5”, Right 

Heading 1 
Style for Next Paragraph: Block, Font:(Default) Times, 12 pt, Bold, English (US), Centered, Line 
spacing: single, Space Before: 14 pt, Widow/Orphan control, Keep with next, Level 1 

Heading 2 
Style for Next Paragraph: Block, Font:(Default) Times, 12 pt, Bold, English (US), Left, Line 
spacing: single, Space Before: 10 pt, Widow/Orphan control, Keep with next, Level 2 

Instruction 
Style for Next Paragraph: Instruction_Expl, Font:(Default) Courier, 11 pt, English (US), Indent: 
Left: 0.2”, Left, Line spacing: single, Space Before: 6 pt, Widow/Orphan control, Keep 
with next 

• • •

Demo 1



CS 200 Spring 2020 02 – Styles11

Showing Style Usage in MS Word
Word > Preferences... The text being formatted

In Draft view, the “style area width” controls 
the width of the style name column in the doc 
display; if it’s zero, the style name column 
vanishes.
In Draft view, View > Reveal Formatting  
to enable the (yellow) Formatting popup 3.99cm
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Showing Style Usage in MS Word cont’d

Word > Styles Pane...
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The underlying concept is indirection
• referring to something through something else

Indirection is useful in many contexts, including...
• drawing programs (object properties)
• HTML (tags in web pages; CSS)
• electronic mail (aliases, forwards)
• spreadsheets (named cells/ranges)

Remember the Model pearl?

13

Indirection
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Style names should reflect function, not appearance
“Quotation” not “Indented Paragraph”
“Emphasis” not “Bold”
“List Item” not “Bulleted Paragraph”

Style names
should be chosen logically

— NOT based on their appearance
so if you change the appearance, 
you don’t have to change the name,  
and you avoid confusion

14

Naming Named Styles
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The idea
• style B is “everything style A is, except for . . .”
• style C is “everything style B is, except for . . .”
• etc.
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Hierarchical Styles

Style A
Helvetica, 24 pt, Bold

Style B

Helvetica, 22 pt, Bold
Style C

Helvetica,24 pt, Italics

Style D
Times, 22 pt, Bold

Style E
Helvetica, 26 pt, Italics
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Hierarchical Styles cont’d
When you change an attribute of A’s definition

• styles based on A change, too, unless that attribute has been explicitly set for the 
derived style

16

Style A
Palatino, 24 pt, Bold

Style B

Palatino, 22 pt, Bold
Style C

Palatino,24 pt, Italics

Style D
Times, 22 pt, Bold

Style E
Palatino, 26 pt, Italics
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Hierarchical Styles Relativity
There are choices in how to implement some aspects of this; 
eg, if I change B’s font size, is the new value

• absolute (MS Word), or relative to the size of A?
• does changing A’s size later automatically change B’s?
• by a fixed number of points, or by a percentage?

Ditto with paragraph indents

Etc.
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Style A
Palatino, 28 pt, Bold

Style B
Palatino, ?? pt, Bold

Style C
Palatino, ?? pt, Italics

Style D
Times, ?? pt, Bold

Style E
Palatino, ?? pt, Italics
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Comments
• this is a MODEL of named styles, though with parameters
• there’s no point to this unless parent and child styles:

• share some attributes
• but not others

• you might have a forest instead of a tree  
(our previous example had no hierarchy at all — a forest of flat trees, so to speak)

In the “Files for Styles Lectures”  under Week 2: Styles on Learn, compare
• User Manual Extract (Tree)
• User Manual Extract (Forest)

18

Hierarchical Styles — Comments
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The Paragraph Styles Tree for User Manual Extract
T

Block_Centered is a poorly chosen name 
because it refers to the appearance of the 
text tagged with this named style, instead of 
the text’s purpose
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Built-in styles
(The names are built-in, however the 
definitions have been altered)

20

A Paragraph Style Sheet for UME.doc Using Multiple Trees

Default Paragraph Font
The font of the underlying paragraph style +

Footer
Normal + Font:10 pt, Right: 0.25", Tabs: 3.25", Centered + 6.5", Right

Footnote Reference
Default Paragraph Font + Superscript

Footnote Text
Normal + Font:10 pt, Justified, Line spacing: exactly 10 pt, Space Before: 
4 pt

Header
Normal + Tabs: 3", Centered + 6", Right

Heading 1
Style for Next Paragraph: Block
Heading_Abstract + Font:Bold, Centered, Space Before: 14 pt, Keep with 
next,
Level 1

Heading 2
Style for Next Paragraph: Block
Heading_Abstract + Font:Bold, Space Before: 7 pt, Keep with next, Level 
2

No List
No List +

Normal
Font:(Default) Times New Roman, 12 pt, English (US), Left, Line spacing:
single, Space Before: 3 pt, Widow/Orphan control

Page Number
Default Paragraph Font +

Table Normal
Font:(Default) Times New Roman, 10 pt, Left, Line spacing: single,
Widow/Orphan control

User-defined styles
Block

Body_Abstract + Justified, Space Before: 6 pt
Block_Centered

Block + Centered, Numbered
Body_Abstract

Normal +
Emphasis_Slight

Default Paragraph Font + Font:Italic
Figure_Caption

Body_Abstract + Font:10 pt, Indent: Left: 0.39", Right: 0.39", Justified, Line
spacing: exactly 12 pt, Space Before: 6 pt

Heading_Abstract
Normal +

Instruction
Style for Next Paragraph: Instruction_Expl
Body_Abstract + Font:Courier, 11 pt, Indent: Left: 0.2", Space Before: 6 pt,
Keep with next

Instruction_Expl
Body_Abstract + Indent: Left: 0.44", Numbered

Instruction_Item
Style for Next Paragraph: Instruction_Expl
Body_Abstract + Font:10 pt, Indent: Left: 0.63", Hanging: 0.19", Line spacing:
exactly 12 pt

Item
Body_Abstract + Indent: Left: 0.19", Hanging: 0.19", Space Before: 6 pt

MenuItem
Body_Abstract + Font:Courier, 11 pt, Indent: Left: 0.19", Line spacing: exactly 
12 pt, Space Before: 9 pt, Numbered

MenuItem_Expl
Body_Abstract + Indent: Left: 0.44"

Operand
Body_Abstract + Indent: Left: 0.25"

Operand_Expl
Body_Abstract + Indent: Left: 0.56", Space Before: 6 pt

• • •Demo 2!
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Should character attributes be part of a paragraph style definition?

Are character styles hierarchical?
• yes in MS Word
• no in FrameMaker
• yes in Nisus Writer Express & Nisus Writer Pro
• yes in Adobe InDesign

Are character styles used to specify the (default) character attributes of paragraph 
styles?

• no in MS Word
• optionally in Nisus Writer Express & Pro

21

Character Styles 

Incidentally, if you own a Mac, Nisus Writer Pro is a very nice $39 US (ed) word processor (www.nisus.com).
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What’s our model of a TOC? (example on the next slide)

Steps to create a table-of-contents
• identify paragraph styles from which to build the TOC

• ex. Heading 1, Heading 2, Heading 3, etc, in Word
• specify a TOC style for each TOC level

• TOC 1, TOC 2, TOC 3, etc, in Word
• build the TOC (most word processors do this for you)

• copy paragraphs with specified paragraph style tags into the TOC
• apply the corresponding TOC style to each

• Heading 1 to TOC 1, Heading 2 to TOC 2, Heading 3 to TOC 3, etc.
• append a tab character & page number to each

• modify the TOC styles to get the desired layout
• rebuild the TOC whenever appropriate

Note the application of two distinct styles to each piece of text

22

Tables-of-Contents (TOCs) 
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Demo — The TOC for User Manual Extract 
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Display or not display  
Print or not print

• in MS Word these are separate attributes
• is that a good idea?

Look up “Hidden Text” in Word’s help index

Word only implements one class of conditional text
• but it makes sense to have more
• you can simulate having more than one  

class of conditional text using named styles

24

Conditional Text

How would 
you do this?
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Format → Style...

25

The Format > Style… Dialog in Word

Interaction techniques A preview checkbox would be better. 
& everywhere—not just here.
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The Format > Style... > Modify Style sub-dialog 
Recall the Model Pearl (interaction)

• Nested dialog boxes 
+ radio buttons, check boxes, etc.

• Which is better? Should you have both?

26

Use this dropdown menu  
to change more attributes



CS 200 Spring 2020 02 – Styles27

The Format > Style... > Organizer sub-dialog 
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Not all paragraph attributes are available in this dialog
ex. bullets, borders...
although they belong here

28

Word’s Format > Paragraph dialog box

when/why “Exactly?”
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Widow
stranded line at top of page

Orphan
stranded line at bottom of 
page

29

Widows and Orphans
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Word’s Format > Font... (ie. Character) dialog box
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Store style definitions in a separate “template” or “style sheet” file

Use templates to keep styles  
consistent across multiple documents

• each such document is linked to the template
• when the template is changed, 

the appearance of every linked document
• changes automatically? (optional in MS Word)
• or do you have to request an update? (Keynote)

Another data model...

31

Style Templates 

Tools g Templates and Add-
ins…
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Style Templates in MS Word 
Every document is based on a template (“Normal” by default)

• apparently in the “~ / Documents / Microsoft User Data / “ 
folder... 
(instead of ~ / Library / Application Support / Microsoft ... sigh)

• whose styles are copied to the document

To use a different base template
• use the “Attach” button in the Tools → Templates and Add-ins…  

dialog box

To have Word reload the template’s styles every time you  
open the document

• check “Automatically Update Document Styles” 
in the Tools → Templates and Add-ins… dialog box

To cause a style change applied in a document to update  
its template definition

• Use the “Add to template” button in the Modify Styles  
dialog box, or change it directly in the template

32
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Character attributes in paragraph styles
• are a matter of convenience
• when done, one set of character attributes is a property of the paragraph as a whole

The Style Column
• is visible only in Outline or Draft View, not Web Layout or Print Layout

Some paragraph attributes
• are in “auxiliary” dialog boxes instead of the paragraph dialog box 

even though they are paragraph attributes
• ex. borders, bullets, numbering, shading

Paragraph attributes
• are “stored in” the ¶ at the end of each paragraph
• are automatically copied to a new paragraph if you press RETURN

• you can copy/paste this character to transfer its attributes to another paragraph

33

Things That May Confuse You in MS Word 
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It’s easier / quicker to change
• the appearance of an existing document
• determine the appearance of a conforming document

They make it easier to achieve consistent appearance
• within a document
• using templates, across documents

You can switch media much more easily

34

The Case For Styles



CS 200 Spring 2020 02 – Styles

It takes longer to get started

35

The Case Against
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In well-designed applications you can do everything via
• menu items
• dialog boxes opened by a menu item
• a toolbar opened from a menu item

— Why?

Often there are other ways of doing things
• typically faster but more obscure

— Why?

Are there other ways to
• DEFINE named styles in Word?
• APPLY named styles In Word?

Explore the Styles pull-down in the Formatting toolbar
• (The Poke pearl)

36

Application Interface and Design 
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Styles & Style Templates (aka “Style Sheets”) Elsewhere
These ideas are applicable anywhere you have objects with attributes, 
though the term may not be used

• graphics applications
• printing
• web pages

So look for them!

37

Huh? Think about this...
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Pixel Graphics
Have a digital photo ready for lab next week.

38

Next Week


