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Lecture 04
Geometric Graphics
(aka Vector Graphics)
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Abbreviations 
aka Also Known As 

dpi Dots Per Inch 

HCGW How Computer Graphics Works (a book) 

NDWB The Non-Designer’s Web Book 

ppi pixels per inch 

Please note that although we are not using Adobe Illustrator, Inkscape follows the same model.

As for Inkscape...
concentrate on what we do, not how we do it

Resources you might like to know about if you own a Mac
“Take Control of Fonts in Mac OS X” by Sharon Aker ($20 eBook) 
http://www.takecontrolbooks.com/fonts-macosx.html

Also available as “Real World Mac OS X Fonts” from Peachpit Press (ISBN 0-321-47401-5, $40 US) 
— and contains “Take Control of Font Problems in Mac OS X,” another eBook by Sharon Aker

Moving fonts back and forth between Windows and Macintosh PCs

TransType, from www.fontlab.com

On either platform: “Real World Adobe Illustrator” by Morty Golding, from www.PeachPit.com (CS2/e, CS3/e or 
CS4/e).
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Miscellaneous Notes
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BEFORE lab this week, please read and high-light 
• Assignment 4 
• This week’s slides 

Major topics this week
• Geometric Graphics 
• Bézier Curves 
• The Toy Pearl 

Visit Learn / Week 4: Geometric Graphics / Files for Geometric Graphics
• for this week’s lecture demo files (Bézier curves), including some short QuickTime movies

Note: the movies created are from a different application (CorelDraw) but the model of Bézier curves is 
the same.

Please ask questions!
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Administrivia
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The Toy Pearl
Toy application documents

• experiment with one feature in a small (ie. simple) document
• so you don’t mess up a “production” document
• so the feature of interest isn’t confused with other features

• save these documents
• so you can come back to them later
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Assumptions
You have now used a pixel graphics program: Gimp or Photoshop

You understand:
• basic geometry
• coordinates of a figure
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Things to Think About
How do the data objects differ in pixel and geometric graphics?

Is there more than one way to do a task?

What are deficiencies/inefficiencies of the interface?

What are efficiencies of the interface?
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(used by GIFs)
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(3 bytes / entry)

255

A Typical 2-d Geometric Graphics Drawing
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To a pixel-graphics program 
• a line is just pixels 
• once drawn, the fact that these approximate a line is forgotten  

— all the program remembers is the pixels 

To a “drawing program” 
• a line is a pair of end-point locations 

• eg. “line from (1,0) to (22,3)”
• the program determines which pixels must be illuminated to represent the line  

but remembers the geometric definition of the line, 
and which pixels were drawn to represent which geometric object;

• if you scale the line by 2x, it re-computes which pixels should be illuminated
• if you click on a pixel generated by the line, 

you can then manipulate the mathematical representation of the line, 
which is “re-rendered” into pixels periodically as you change it 
(remember — video memory is re-displayed every 60th of a second or more)
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“A (geometric graphics) drawing is a collection of geometric objects”
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Pixel Graphics 
• the program manipulates pixels 
• you zoom an image by replicating pixels 
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Pixel vs Geometric Graphics (1) T
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Pixel Graphics 
• the program manipulates pixels 
• you zoom an image by replicating pixels 
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Pixel vs Geometric Graphics (2)
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Pixel Graphics 
• the program manipulates pixels 
• you zoom an image by replicating pixels 
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Pixel vs Geometric Graphics (3)
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Pixel Graphics 
• the program manipulates pixels 
• you zoom an image by replicating pixels 
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Pixel vs Geometric Graphics (4)
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Pixel Graphics 
• the program manipulates pixels 
• you zoom an image by replicating pixels 
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Pixel vs Geometric Graphics (5) T

Our triangle, at 2x zoom
Notice the increased jaggedness
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Geometric Graphics 

• “sit on top of” pixel graphics

• you define geometric objects (lines, rectangles, circles, etc)

• the program 
• remembers these objects 
• allows you to reshape/edit them 
• re-draws them in video memory whenever they are altered 

• so when you zoom in on the triangle, say by 2x
• first you scale up the triangle
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Pixel vs Geometric Graphics (6) T
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Geometric Graphics 

• “sit on top of” pixel graphics

• you define geometric objects (lines, rectangles, circles, etc)

• the program 
• remembers these objects 
• allows you to reshape/edit them 
• re-draws them in video memory whenever they are altered 

• so when you zoom in on the triangle, say by 2x
• first you scale up the triangle 
• then you determine which pixels are covered by the new & larger triangle

15

Pixel vs Geometric Graphics (6)
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Pixel vs Geometric Graphics (7)

Pixel Graphics
— pixel replication

Geometric Graphics
— scale the object
— then recompute pixels

A Geometric Graphics program zooms an image by scaling objects mathematically before re-drawing 
them 

• no pixel replication 

• no additional jaggedness
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Drawing familiar objects 
• lines and polygons 
• ellipses and circles, 

rectangles and squares

— shift-click-drag to “constrain” the object to a circle/square/...

— option-click-drag to draw from the center 

Quasi-familiar objects 
• text 

Drawing unfamiliar objects 
• Bézier curves & regions 
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Drawing Standard Geometric Objects
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Select objects with the selection tool 
• Click on object 

Selection handles (common to many apps) 
• click once on an object to display them 
• click-drag a selection handle to scale the image
• shift-click-drag on a handle to preserve the aspect ratio
• click-drag the object itself to move it

Rotation handles 

• Using the selection tool, click on the object again

• Now the selection handles allow you to rotate the object

• You can also use the rotation icons in the toolbar 

Selecting multiple objects 

• shift-click layers

• click–drag to surround all of them 

• — either yields one set of common selection handles

Note that in Inkscape, you use ctrl instead of cmd like in Windows programs.
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Manipulating Objects as a Whole

The “opt” Mac key 
= the “alt” Win key
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Objects are drawn (“rendered”) into video memory in some order 
• drawn first ➯ behind 
• drawn last ➯ in front 

You can change the order…

If objects are in the same layer…
• select an object by clicking on it
• use these menu items to move the object up and down

To put objects in different layers (recommended)…
• select an object by clicking on it
• right click on the object and select “Move to layer…”
• select the destination layer
• Alternatively, create a new layer first (Layer > Add Layer…) and make an object in this layer

Changing order of layers…
• Use the arrows in the layers panel (show this panel by Layer > Layers…) 
• or use the options in the Layer menu

Layer Icons…
For each layer, click icons to say 

•  visible / invisible 
•  write-protected / writable
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Stacking Objects — Who’s on Top?
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Stroke 
• line thickness 
• boundary colour 
• fill colour
• dash pattern 
• corner and end cap shape
• arrowheads & other “effects” 

Hmm.  
There’s not much difference  
between lines (aka “paths”) 
and regions (aka “shapes”)

• open vs closed paths
• open paths have an interior... 

and so can be filled

20

Properties
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Fill 
• fill the interior of an object in various ways 
• (including none) 
• For a good time, try gradient fills 

Transparency (opacity = 100% – transparency)

21

More Properties T
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View > Display Mode > Normal

View > Display Mode > Outline

View > Display Mode > No Filters

Note that changing the display settings doesn’t 
change how it would appear when saved/
exported as an image file, or how it would 
appear when printed.
View > Colour Display Mode > Normal

View > Colour Display Mode > Grayscale

22

View Modes
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“Anchor Points” are where curve “segments” connect (“join”)
• this curve below has 5 segments 

“Direction Lines” (aka “Control Vectors”) determine the curve’s direction at an anchor point
• they extend from an anchor point to a “direction point” (aka “control point”) 
• direction lines are tangent to the curve at the anchor point

Anchor Point types 
• “corner” or “cusp” — the incoming & outgoing directions (ie tangents) are different (the corner is sharp) 
• “smooth” — the incoming & outgoing directions (ie tangent directions) are the same
• “symmetric” —  smooth, and the direction lines are the same length

Look up “pen tool” and “reshape curve” in Help > Photoshop Help
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Bézier Curves
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Figure 4.13 on page 85
of “The Design of Life”
by Renato Dulbecco 
(1987).

A fairly typical CS 135 
slide.

size
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"Ginny"

"Hermione"
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Figure 8.3 on page 152
of “The Design of Life”
by Renato Dulbecco 
(1987).
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Click the Pen tool button 

Click–drag–release repeatedly to define each segment 
• click to place the next anchor point (node) 
• then drag to pull out that anchor point’s outgoing direction line 

Click-release, click-drag elsewhere  
to create a corner point with no direction lines

Open Curve: double-click or press Enter when you’re finished defining an open curve 
Closed Curve: click-drag on the starting point to finish creating a closed curve

Important hints! 
• the fewer anchor points, the better — it makes the curve easier to reshape 
• don’t try to edit the curve as you (initially) draw it

• you can add (new) intermediate anchor points later (see next slide)
• to change one direction point without the other, press shift while moving the direction points
• to create a node with only one direction point, press shift before making direction points
• to extend a Bézier curve created previously 

• select the existing Bézier curve
• select the Pen (Bézier) tool        and move it over the relevant end point

• the end node changes from white to red when you’re over the end point
• click on the end anchor point and

• drag elsewhere to create a smooth join & another segment, or
• release and click-drag elsewhere to create a corner join & another segment
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Creating a Bézier Curve



CS 200 Winter 2018 Geometric Graphics

Use the Edit Paths by Nodes Tool 

To move an anchor point 
• click on the curve in a segment ending at the anchor point, or 

click-drag to create a selection box containing the anchor point 
• then click-drag the anchor point

To change the direction of a curve at an anchor point 
• click on a curve segment ending at that anchor point, or 

drag a selection box around the anchor point to select it, 
thus making its direction lines visible

• then click-drag one of the anchor point’s direction points
• to move a direction point individually, click on the node and then click         in the toolbar to make the 

selected nodes a corner

See online help for more detail (& stay away from the pencil tool...)

There are movies illustrating the above on oscar in
Learn / Week 4: Geometric Graphics / Files for Geometric Graphics / Bézier Movies

You can also click-drag on the curve itself
• but that usually isn’t very useful;
• somewhat better: click drag to select & move one or more segments
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Editing (Reshaping) a Bézier Curve
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You can also 
• add an anchor point 
• delete an anchor point 
• change a smooth join to a corner join; 

this allows you to edit the direction  
vectors independently

• change a corner join to a smooth join
• join two end anchor points 
• cut a curve into pieces
• continue an existing curve
• and other stuff... 

— poke around (try control-clicking) 
— see Inkscape’s online help

Suggestion: learn how Bézier curves work by playing with toy curves  
before you do the assignment

• serious geometric graphics programs now all have Bézier curves, 
though the terminology & interaction techniques vary

• also, they’re usually just called “curves” or “paths”

Fill, stroke, transparency & other properties just as for rectangles, etc 
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Other things you can do to a Bézier curve
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Letter forms are represented by curved outlines 

Guess how that’s done 

Adobe Type 1 “Postscript fonts” (Type 1)
• an adjunct of the postscript page description language  

that made laser printers so attractive in the mid-eighties 
• underlay the Macintosh’s early success
• comprised of two files

one containing “bit-mapped” screen fonts at particular sizes

one containing outline font definitions, for use when printing

TrueType (TT)
• created by Apple in the 80’s because Adobe charged so much for licensing Type 1 technology
• subsequently adopted by Microsoft
• not as flexible as Type 1 format & harder for designers to work with
• Apple & Microsoft TT font files have different formats; 

Macs support both formats.

OpenType (OT)
• created by Microsoft (1996–2000), later adopted by Adobe
• wraps & extends both Type 1 and TrueType font formats; works on both Macs and Windows PCs
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Text
Text – Outline Fonts

Yup, you guessed right — Bézier curves!
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The Fonts Menu in Inkscape

This is the text menu icon
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How Text is Displayed

from HCGW, p 66
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Because they are “geometry-based” they scale w/o increased jaggedness
• although “optical” adjustments are needed for large scale changes

Contain lots of advanced typographic information for better visual appearance
• eg for “kerning”

What’s So Great About Outline Fonts (esp TT Fonts)?
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Adobe Arne Pro Italic 
—intended point size ranges 

Caption: 5 to 8.5 point 
SmText: 8.6 to 11 point 
Regular: 11.1 to 14 point 
Subhead: 14.1 to 21.5 point 
Display: 21.5 point or larger

Adobe Minion MultiMaster

The point is that these examples are designed for use at different 
sizes, 

but are displayed here scaled to the same size so you can compare 
the designs.

The individual font names suggest roughly what range of sizes each 
font is intended for.

ToTo
TheThe
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“Point text” (aka “label text”)
• just click and start typing

“Area text” (aka “paragraph text”) 

“Path Text”
• An example of text “wrapped” along a path. 

Explore the Type menu, Type tool, and online help
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Text in Inkscape

Toolbar Icon

Text Menu

Text Options Panel
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Select text, then go to Path > Object to Path
• converts text to graphical objects

• whose outlines are Bézier curves

34

Converting text to Bézier shapes
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For special characters, look up “Keyboard Viewer” and/or “Character Palette”

35

/ Applications / Font Book (OS X)
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Vary the intensity of pixels  to make edges look smoother 

How it’s done
Model a line as a 1-pixel-wide rectangle.

Set the intensity of each pixel to be 255 times the fraction of 
the pixel that intersects the rectangle. 

Works for ALL kinds of graphics
eg for the edges of regions

eg for text

In fact, Acrobat Reader anti-aliases text 
with variable success 

(it depends on how the lookup table is set) 

So do Mac OS X 
System Preferences 

> Appearance  
> Use LCD font smoothing when available

and Windows XP
though apparently you  
have to turn it on  
(next slide)
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Anti-Aliasing A line with no anti-aliasing

The same line w/anti-aliasing

from HCGW, p 70
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Anti-Aliasing in Windows XP

Example from
http://www.microsoft.com/typography/cleartype/tuner/
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Use “Standard” for 
CRTs; 
Use “ClearType” for 
LCDs.
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Everything is a Bézier curve 
• select an object with the Edit Paths by Node tool            to see the anchor points;

• click on an anchor point to see its direction vectors

• zooming helps when working with closely-packed  
anchor points or short direction vectors 

• for a default object like a circle, square, or text, first select the object, then select Path > Object to Path. 
You can then edit it as above.

Object > Group
• select / move / scale several objects as if they were one 

Layer > Lock/Unlock Current Layer
• turn off select / edit capability 

View > Page Grid

File > Document Properties > Snap > Always Snap
• make objects snap to grid

View > Guides
Poke and/or read online help for details as necessary
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Other Important Concepts
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Inkscape’s interface is a little different than other applications we have looked at
• it doesn’t use Apple’s toolbar, but has a toolbar within the window like Windows programs.
• It also uses ctrl instead of cmd like Windows programs, even when running on a Mac.  

Right-click for contextual menus 

To find out what a button does 
• Try it (the Poke pearl)
• Hover over the button to see a “tool tip”
• Look it up in online help 

• ex. by searching for the name shown in the tool tip) 
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Learning to Drive Inkscape 
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Aside — Text in Photoshop — Lest you be confused...
Text in Photoshop is placed in a “type layer”

where it is treated as a geometric object

It can be edited, provided it’s kept in that type layer; 
if you merge it with another layer, it’s converted to pixels (“rasterized, rendered”), 
and can no longer be edited, 
though you can then apply standard image transformations/manipulations.

So ... text in Photoshop is really
a geometric component

in an otherwise pixel graphics application

Well, actually...Photoshop also has “paths,” “shapes,” and “vector masks”
these are also geometric objects (that you can stroke or fill, or use as masks)

they can be manipulated with Photoshop-like geometric tools

but unfortunately we don’t have time to explore them — see online help (or 3rd party books) if you’re 
curious
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Hmm. 
Characters and paragraphs have properties ... 

Often it’s convenient to name collections of these ... 

Does it make sense to have named graphical styles, too? 

Would that be useful?

Be sure you understand the difference between 
• what’s in a Inkscape/geometric layer
• Don’t let these confuse you about the difference between pixel & geometric graphics

41

Final Comments
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Selection
you can click on an object in the canvas to select it

would it be helpful to also be able to click on an object through the layers palette?

Stacking order
you can change the stacking order of objects within a layer

you can change the stacking order of layers

— why have both capabilities?
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Study Questions


