Assigned Readings:
• "The Non–Designer’s Design Book," by Robin Williams (first half)
• “Adobe on Basic Typography” (https://www.student.cs.uwaterloo.ca/~cs200/Adobe/main.html)

Please read and highlight before this week’s lab
• Assignment 2 (due Tuesday May 21 at 11:59 pm)
• Notes for this lecture

Today and Thursday
• [named] styles
• the Poke pearl
• backups
<table>
<thead>
<tr>
<th>What happens if you</th>
<th>What happens if you</th>
</tr>
</thead>
<tbody>
<tr>
<td>• double-click here?</td>
<td>• click and drag on this?</td>
</tr>
<tr>
<td>• triple-click here?</td>
<td>• option-click and drag on this?</td>
</tr>
<tr>
<td>• option-click here?</td>
<td>• control-click and drag on this?</td>
</tr>
<tr>
<td>• control-click here?</td>
<td>• command-click and drag on this?</td>
</tr>
<tr>
<td>• command-click here?</td>
<td>• etc...</td>
</tr>
<tr>
<td>• etc...</td>
<td>• etc...</td>
</tr>
</tbody>
</table>

THE POKE PEARL
ASSUMPTIONS

☐ You have used a word processor before

☐ You understand and correctly use the following WP tools
  • Word Wrap (hard carriage return vs. soft carriage return)
  • Cut/Copy and Paste
  • Font usage (size, style and typeface)
  • Rulers and Margins
  • Proper use of tabs
  • Headers and footers (page numbering)
  • Footnotes
THINGS TO THINK ABOUT

- What are the data objects in a Word Processor?
- Is there more than one way to do any given task?
- What are deficiencies of the interface?
- What are efficiencies of the interface?
The idea
• name a collection of paragraph or character attributes
• you then apply the NAME to text instead of individually setting attributes

Hence changing a document's appearance is
• easier & faster, more accurate (consistency, if used intelligently)
• — you just change the definition of the name; everywhere it's used, text changes

Does appearance matter? → Yes!
• legibility
• understandability
• professionalism
Named Styles (2)

Terminology

• Attributes: Helvetica, Palatino, bold, italic, underlined, red, 15 pt leading, etc. are **attributes**
• [Named Style]: A (named) style is a (specific) “bundle of attributes”
• We usually specify that it is a “named style” for emphasis/clarity
  • ex. “Heading” could be a named style with attributes
    “24 pt Myriad Pro Light with 12 pts of Before Paragraph leading & 2 cm of left indent”
Compare this and the preceding slide

Terminology Attributes: Helvetica, Palatino, bold, italic, underlined, red, 15 pt leading, etc. are attributes [Named Style]: A (named) style is a (specific) “bundle of attributes” We usually specify that it is a “named style” for emphasis/clarity ex. “Heading” could be a named style with attributes “24 pt Myriad Pro Light with 12 pts of Before Paragraph leading & 2 cm of left indent”
INDIRECTION

The underlying concept is indirection

• referring to something through something else

Indirection is useful in many contexts, including...

• drawing programs (object properties)
• HTML (tags in web pages; CSS)
• electronic mail (aliases, forwards)
• spreadsheets (named cells/ranges)

Remember the Model pearl?
Style names should reflect function, not appearance
“Quotation” not “Indented Paragraph”
“Emphasis” not “Bold”
“List Item” not “Bulleted Paragraph”

Style names should be chosen logically
— NOT based on their appearance
so if you change the appearance,
you don’t have to change the name,
and you avoid confusion
Showing Style Usage in MS Word

In Draft view, the "style area width" controls the width of the style name column in the doc display; if it's zero, the style name column vanishes.

In Draft view, View > Reveal Formatting to enable the (yellow) Formatting popup.
Showing Style Usage in MS Word cont’d

Home > Styles Pane... to bring up
Hierarchical Styles

The idea

• style B is “everything style A is, except for . . .”
• style C is “everything style B is, except for . . .”
• etc.

Style A
Helvetica, 24 pt, Bold

Style B
Helvetica, 22 pt, Bold

Style D
Times, 22 pt, Bold

Style C
Helvetica, 24 pt, Italics

Style E
Helvetica, 26 pt, Italics
Hierarchical Styles Cont’d

When you change an attribute of A’s definition
• styles based on A change, too, unless that attribute has been explicitly set for the derived style

Style A
Helvetica, 24 pt, Bold

Style B
Helvetica, 22 pt, Bold

Style C
Helvetica, 24 pt, Italic

Style D
Times, 22 pt, Bold

Style E
Helvetica, 26 pt, Italic
Hierarchical Styles Relativity

There are choices in how to implement some aspects of this; eg, if I change B's font size, is the new value

- absolute (MS Word), or relative to the size of A?
- does changing A's size later automatically change B's?
- by a fixed number of points, or by a percentage?

Ditto with paragraph indents

Etc.

Style A
Palatino, 28 pt, Bold

Style B
Palatino, ?? pt, Bold

Style C
Palatino, ?? pt, Italics

Style D
Times, ?? pt, Bold

Style E
Palatino, ?? pt, Italics
Hierarchical Styles — Comments

- this is a MODEL of named styles, though with parameters
- there’s no point to this unless parent and child styles:
  - share some attributes
  - but not others
- you might have a forest instead of a tree
  (our previous example had no hierarchy at all — a forest of flat trees, so to speak)

- In the “Files for Styles Lectures” under Week 2: Styles on Learn, compare
  - User Manual Extract (Tree)
  - User Manual Extract (Forest)
The Paragraph Styles Tree for User Manual Extract

Block_Centered is a poorly chosen name because it refers to the appearance of the text tagged with this named style instead of the text's purpose.
A Paragraph Style Sheet for UME.doc Using Multiple Trees

Built-in styles
(The names are built-in, however the

User-defined styles

<table>
<thead>
<tr>
<th>Style</th>
<th>Font</th>
<th>Align</th>
<th>Space Below</th>
<th>Space Above</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>Times New Roman, 12 pt, English (US), Left, Line spacing: single, Widow/Orphan control</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Demo 2!
Character Styles

Should character attributes be part of a paragraph style definition?

Are character styles hierarchical?
  - yes in MS Word
  - no in FrameMaker
  - yes in Nisus Writer Express & Nisus Writer Pro
  - yes in Adobe InDesign

Are character styles used to specify the (default) character attributes of paragraph styles?
  - no in MS Word
  - optionally in Nisus Writer Express & Pro
Tables-of-Contents (TOCs)

- What's our model of a TOC? (example on the next slide)
- Steps to create a table-of-contents
  - identify paragraph styles from which to build the TOC
    - ex. Heading 1, Heading 2, Heading 3, etc, in Word
  - specify a TOC style for each TOC level
    - TOC 1, TOC 2, TOC 3, etc, in Word
  - build the TOC (most word processors do this for you)
  - copy paragraphs with specified paragraph style tags into the TOC
  - apply the corresponding TOC style to each
    - Heading 1 to TOC 1, Heading 2 to TOC 2, Heading 3 to TOC 3, etc.
  - append a tab character & page number to each
  - modify the TOC styles to get the desired layout
  - rebuild the TOC whenever appropriate
- Note the application of two distinct styles to each piece of text
Demo — The TOC for User Manual Extract

Main Commands in the Machine Emulator (XEM)

- The "super window" shows the contents of the data and code memory. On Unix and Windows computers, it contains a window from which the contents can be controlled. On Macintosh, menu items are displayed at the top of the screen.
- The "memory window" shows a virtual display of the contents of memory.

File Menu (XEM Menu on the Macintosh)

- Use the commands to load a new program, which is then displayed in memory. Switch "new file" commands are only available in memory.

Search

- Use the commands to select and print the contents of the current executable files. This includes the memory and the code memory.

Exit

- Terminate execution of the emulator

Execute Menu

- Execute a single instruction and step. Clicking on the same number's step button is equivalent to executing the entire line.

When you execute an instruction, certain registers and the program counter are updated in the same way. The program counter increments the address of the next instruction. The registers that are updated may vary depending on the instruction executed.

The program counter is the memory location that contains the address of the next instruction that is going to be executed. When you execute an instruction, the program counter is updated to point to the next instruction.

The program counter is updated by adding the length of the instruction to the current value of the program counter.

Table of Contents

Main Commands in the Machine Emulator (XEM) ........................................1
Execute Menu .................................................................2
Display Menu .................................................................3
XEM's Architecture ..........................................................4
Program Counter ............................................................4
Instruction Register .........................................................4
CPU Register ...............................................................4
Condition Code Register ..................................................4
The Instruction Set and Assembly Syntax ............................................7
Data Movement ............................................................7
Arithmetic / Logical Instructions ...............................................8
Flow of Control ..............................................................8
Pseudo Instructions ........................................................8
The Trap Instructions .......................................................11
Trap 1: Reading an Integer ................................................11
Trap 2: Write an integer to the display and to the display, two times 11
Trap 3: Write an integer to the display and to the display, three times 11
Trap 4: Write an integer to the display and to the display, six times 11
Trap 5: Write an integer to the display, to the display, six times 11
Trap 6: Read a string ......................................................12
Trap 7: Write a setting to the display and to the display 12
Trap 8: Write a setting to the display and to the display 12
Comments .................................................................13
Conditional Text

Display or not display
Print or not print
  • in MS Word these are separate attributes
  • is that a good idea?

Look up “Hidden Text” in Word’s help index

Word only implements one class of conditional text
  • but it makes sense to have more
  • you can simulate having more than one class of conditional text using named styles

How would you do this?
The Format > Style… Dialog in Word

Format → Style...

Interaction techniques

A preview checkbox would be better. & everywhere—not just here.
The Format > Style... > Modify Style sub-dialog

Recall the Model Pearl (interaction)

- Nested dialog boxes
  - radio buttons, check boxes, etc.
- Which is better? Should you have both?

Use this dropdown menu to change more attributes
The Format > Style... > Organizer sub-dialog
Word’s Format > Paragraph dialog box

Not all paragraph attributes are available in this dialog
ex. bullets, borders...
although they belong here

when/why “Exactly?”
Widows and Orphans

Widow
stranded line at top of page

Orphan
stranded line at bottom of page
Word's Format > Font... (ie. Character) dialog box
Style Templates

Store style definitions in a separate “template” or “style sheet” file.

Use templates to keep styles consistent across multiple documents:
- each such document is linked to the template;
- when the template is changed, the appearance of every linked document;
- changes automatically? (optional in MS Word);
- or do you have to request an update? (Keynote);

Another data model…

Tools → Templates and Add-ins…
Every document is based on a template ("Normal" by default)
  • apparently in the "~/Documents/Microsoft User Data/" folder...
    (instead of "~/Library/Application Support/Microsoft... sigh)
  • whose styles are copied to the document
To use a different base template
  • use the "Attach" button in the Tools → Templates and Add-Ins… dialog box
Style Templates in MS Word

To have Word reload the template’s styles every time you open the document:
• check “Automatically Update Document Styles” in the Tools → Templates and Add-ins… dialog box

To cause a style change applied in a document to update its template definition:
• Use the “Add to template” button in the Modify Styles dialog box, or change it directly in the template
“Invisible” (aka “non-printing”) characters

See Word’s Preferences > View dialog
Or, press ¶ from Word’s Home menu
Things That May Confuse You in MS Word

- Character attributes in paragraph styles
  - are a matter of convenience
  - when done, one set of character attributes is a property of the paragraph as a whole
- The Style Column
  - is visible only in Outline or Draft View, not Web Layout or Print Layout
- Some paragraph attributes
  - are in “auxiliary” dialog boxes instead of the paragraph dialog box
  - even though they are paragraph attributes
  - ex. borders, bullets, numbering, shading
- Paragraph attributes
  - are “stored in” the ¶ at the end of each paragraph
  - are automatically copied to a new paragraph if you press RETURN
  - you can copy/paste this character to transfer its attributes to another paragraph
The Case For Styles

- It's easier / quicker to change
  - the appearance of an existing document
  - determine the appearance of a conforming document
- They make it easier to achieve consistent appearance
  - within a document
  - using templates, across documents
- You can switch media much more easily
The Case Against

It takes longer to get started
Application Interface and Design

- In well-designed applications you can do everything via
  - menu items
  - dialog boxes opened by a menu item
  - a toolbar opened from a menu item
    - Why?

- Often there are other ways of doing things
  - typically faster but more obscure
    - Why?

- Are there other ways to
  - DEFINE named styles in Word?
  - APPLY named styles in Word?

- Explore the Styles pull-down in the Formatting toolbar
  - (The Poke pearl)
Huh? Think about this…

So look for them!

Styles & Style Templates (aka “Style Sheets”) Elsewhere

These ideas are applicable anywhere you have objects with attributes, though the term may not be used

Graphic Applications
Printing
Web Pages
NEXT WEEK

- Pixel Graphics
- Have a digital photo ready for lab next week