Miscellaneous Notes

- **Assigned Readings:**
  - “The Non–Designer’s Design Book,” by Robin Williams (first half)

- **Please read and highlight before this week’s lab**
  - Assignment 2 (due Tuesday May 21 at 11:59 pm)
  - Notes for this lecture

- **Today and Thursday**
  - [named] styles
  - the Poke pearl
  - backups
### THE POKE PEARL

<table>
<thead>
<tr>
<th>What happens if you</th>
<th>What happens if you</th>
</tr>
</thead>
<tbody>
<tr>
<td>• double-click here?</td>
<td>• click and drag on this?</td>
</tr>
<tr>
<td>• triple-click here?</td>
<td>• option-click and drag on this?</td>
</tr>
<tr>
<td>• option-click here?</td>
<td>• control-click and drag on this?</td>
</tr>
<tr>
<td>• control-click here?</td>
<td>• command-click and drag on this?</td>
</tr>
<tr>
<td>• command-click here?</td>
<td>• etc...</td>
</tr>
<tr>
<td>• etc...</td>
<td>• etc...</td>
</tr>
</tbody>
</table>

### ASSUMPTIONS

- You have used a word processor before
- You understand and correctly use the following WP tools:
  - Word Wrap (hard carriage return vs. soft carriage return)
  - Cut/Copy and Paste
  - Font usage (size, style and typeface)
  - Rulers and Margins
  - Proper use of tabs
  - Headers and footers (page numbering)
  - Footnotes
THINGS TO THINK ABOUT

What are the data objects in a Word Processor?

Is there more than one way to do any given task?

What are deficiencies of the interface?

What are efficiencies of the interface?

[Named] Styles (1)

The idea
- name a collection of paragraph or character attributes
- you then apply the NAME to text instead of individually setting attributes

Hence changing a document’s appearance is
- easier & faster, more accurate (⇒ consistency, if used intelligently)
- — you just change the definition of the name; everywhere it’s used, text changes

Does appearance matter? → Yes!
- legibility
- understandability
- professionalism
Named Styles (2)

Terminology

• Attributes: Helvetica, Palatino, bold, italic, underlined, red, 15 pt leading, etc. are attributes

• [Named Style]: A (named) style is a (specific) “bundle of attributes”

• We usually specify that it is a “named style” for emphasis/clarity

• ex. “Heading” could be a named style with attributes “24 pt Myriad Pro Light with 12 pts of Before Paragraph leading & 2 cm of left indent”

Compare this and the preceding slide

Terminology Attributes: Helvetica, Palatino, bold, italic, underlined, red, 15 pt leading, etc. are attributes [Named Style]: A (named) style is a (specific) “bundle of attributes” We usually specify that it is a “named style” for emphasis/clarity ex. “Heading” could be a named style with attributes “24 pt Myriad Pro Light with 12 pts of Before Paragraph leading & 2 cm of left indent”
INDIRECTION

The underlying concept is indirection

• referring to something through something else

Indirection is useful in many contexts, including...

• drawing programs (object properties)
• HTML (tags in web pages; CSS)
• electronic mail (aliases, forwards)
• spreadsheets (named cells/ranges)

Remember the Model pearl?

DEMO 1

The text being formatted

The style definitions (built-in & user-defined)
Naming Named Styles

Style names should reflect function, not appearance
“Quotation” not “Indented Paragraph”
“Emphasis” not “Bold”
“List Item” not “Bulleted Paragraph”

Style names should be chosen logically
— NOT based on their appearance
so if you change the appearance,
you don’t have to change the name,
and you avoid confusion

Showing Style Usage in MS Word

In Draft view, the “style area width” controls the width of the style name column in the doc display; if it’s zero, the style name column vanishes.
In Draft view, View > Reveal Formatting to enable the (yellow) Formatting popup
Hierarchical Styles

The idea

- style B is “everything style A is, except for . . .”
- style C is “everything style B is, except for . . .”
- etc.

Style A
Helvetica, 24 pt, Bold

Style B
Helvetica, 22 pt, Bold

Style C
Helvetica, 24 pt, Italics

Style D
Times, 22 pt, Bold

Style E
Helvetica, 26 pt, Italics
When you change an attribute of A's definition

- styles based on A change, too, unless that attribute has been explicitly set for the derived style

Hierarchical Styles Relativity

There are choices in how to implement some aspects of this; eg, if I change B's font size, is the new value

- absolute (MS Word), or relative to the size of A?
- does changing A's size later automatically change B's?
- by a fixed number of points, or by a percentage?

Ditto with paragraph indents

Etc.
Hierarchical Styles — Comments

Comments
- this is a MODEL of named styles, though with parameters
- there’s no point to this unless parent and child styles:
  - share some attributes
  - but not others
- you might have a forest instead of a tree
  (our previous example had no hierarchy at all — a forest of flat trees, so to speak)

In the “Files for Styles Lectures” under Week 2: Styles on Learn, compare
- User Manual Extract (Tree)
- User Manual Extract (Forest)

The Paragraph Styles Tree for User Manual Extract

Block_Centered is a poorly chosen name because it refers to the appearance of the text tagged with this named style, instead of the text’s purpose.
A Paragraph Style Sheet for UME.doc Using Multiple Trees

User-defined styles

<table>
<thead>
<tr>
<th>Block</th>
<th>Body_Abbrev + Justified, Space Before: 6 pt</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block</td>
<td>Body_Abbrev + Centered, Numbered</td>
</tr>
<tr>
<td>Normal</td>
<td>Emphasis_Sign</td>
</tr>
<tr>
<td></td>
<td>Default Paragraph Font + Font:italic</td>
</tr>
<tr>
<td>Figure</td>
<td>Caption</td>
</tr>
<tr>
<td>Body</td>
<td>Abstract + Font:10 pt, Indent: Left: 0.38&quot;, Right: 0.38&quot;, Justified, Line spacing: exactly 12 pt, Space Before: 6 pt</td>
</tr>
<tr>
<td>Heading, Abstract</td>
<td>Normal +</td>
</tr>
<tr>
<td></td>
<td>Style for Next Paragraph: Instruction, Expl</td>
</tr>
<tr>
<td></td>
<td>Body_Abbrev + Font:Counter, 11 pt, Indent: Left: 0.2&quot;, Space Before: 6 pt, Keep with next</td>
</tr>
<tr>
<td>Instruction_Expl</td>
<td>Body_Abbrev + Indent: Left: 0.44&quot;, Numbered</td>
</tr>
<tr>
<td>Instruction_Item</td>
<td>Style for Next Paragraph: Instruction, Expl</td>
</tr>
<tr>
<td></td>
<td>Body_Abbrev + Font:10 pt, Indent: Left: 0.6&quot;, Hanging: 0.19&quot;, Line spacing: exactly 12 pt</td>
</tr>
<tr>
<td>Item</td>
<td>Body_Abbrev + Indent: Left: 0.15&quot;, Hanging: 0.19&quot;, Space Before: 6 pt</td>
</tr>
<tr>
<td>MenuItem</td>
<td>Body_Abbrev + Font:Counter, 11 pt, Indent: Left: 0.10&quot;, Line spacing: exactly 12 pt, Space Before: 6 pt, Numbered</td>
</tr>
<tr>
<td>MenuItem_Expl</td>
<td>Body_Abbrev + Indent: Left: 0.44&quot;</td>
</tr>
<tr>
<td>Operand</td>
<td>Body_Abbrev + Indent: Left: 0.25&quot;</td>
</tr>
<tr>
<td>Operand_Expl</td>
<td>Body_Abbrev + Indent: Left: 0.60&quot;, Space Before: 6 pt</td>
</tr>
</tbody>
</table>

Built-in styles
(The names are built-in, however the)

Default Paragraph Font
The font of the underlying paragraph style +

Footer
Normal + Font:10 pt, Right: 0.25", Tab: 3.00", Centered + 6.0", Right

Footnote Reference
Default Paragraph Font + Superscript

Footnote Text
Normal + Font:10 pt, Justified, Line spacing: exactly 10 pt, Space Before: 4 pt

Header
Normal + Tab: 3", Centered + 6", Right

Heading 1
Style for Next Paragraph: Block
Heading_Abbrev + Font:Bold, Centered, Space Before: 14 pt, Keep with next,
Level 1

Heading 2
Style for Next Paragraph: Block
Heading_Abbrev + Font:Bold, Space Before: 7 pt, Keep with next, Level 2

No List

Normal
Font:DejaVu Sans, 12 pt, English (US), Left, Line spacing: single, Space Before: 3 pt, Widow/Orphan control

Page Number
Default Paragraph Font +

Table Normal
Font:DejaVu Sans, 10 pt, Left, Line spacing: single, Widow/Orphan control

Character Styles

☑ Should character attributes be part of a paragraph style definition?

☑ Are character styles hierarchical?
  • yes in MS Word
  • no in FrameMaker
  • yes in Nisus Writer Express & Nisus Writer Pro
  • yes in Adobe InDesign

☑ Are character styles used to specify the (default) character attributes of paragraph styles?
  • no in MS Word
  • optionally in Nisus Writer Express & Pro

Demo 2!
Tables-of-Contents (TOCs)

What's our model of a TOC? (example on the next slide)

Steps to create a table-of-contents

- identify paragraph styles from which to build the TOC
  - ex. Heading 1, Heading 2, Heading 3, etc., in Word
- specify a TOC style for each TOC level
  - TOC 1, TOC 2, TOC 3, etc., in Word
- build the TOC (most word processors do this for you)
  - copy paragraphs with specified paragraph style tags into the TOC
  - apply the corresponding TOC style to each
    - Heading 1 to TOC 1, Heading 2 to TOC 2, Heading 3 to TOC 3, etc.
  - append a tab character & page number to each
  - modify the TOC styles to get the desired layout
  - rebuild the TOC whenever appropriate

Note the application of two distinct styles to each piece of text

---

Demo — The TOC for User Manual Extract

<table>
<thead>
<tr>
<th>Table of Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu Commands in the Machine Emulator (GEM)</td>
</tr>
<tr>
<td>File Menu (GEM Menu on the Mainboard)</td>
</tr>
<tr>
<td>Execute Menu</td>
</tr>
<tr>
<td>Display Menu</td>
</tr>
<tr>
<td>GEM’s Architecture</td>
</tr>
<tr>
<td>Program Counter</td>
</tr>
<tr>
<td>Instruction Register</td>
</tr>
<tr>
<td>Memory</td>
</tr>
<tr>
<td>CPU Registers</td>
</tr>
<tr>
<td>Condition Code Register</td>
</tr>
<tr>
<td>The Instruction Set and Assembly Syntax</td>
</tr>
<tr>
<td>Data Movement</td>
</tr>
<tr>
<td>Arithmetic / Logical Instructions</td>
</tr>
<tr>
<td>Flow of Control</td>
</tr>
<tr>
<td>Pseudo Instructions</td>
</tr>
<tr>
<td>The Trap Instructions</td>
</tr>
<tr>
<td>Top 01 — Reading an integer</td>
</tr>
<tr>
<td>Top 02 — Write an integer to the display and to the listing, base 10</td>
</tr>
<tr>
<td>Top 03 — Write an integer to the display, base 10</td>
</tr>
<tr>
<td>Top 04 — Write an integer to the display and to the listing, in some fields</td>
</tr>
<tr>
<td>Top 05 — Write an integer to the display, in some fields</td>
</tr>
<tr>
<td>Top 06 — Read a string</td>
</tr>
<tr>
<td>Top 07 — Write a string to the display and to the listing</td>
</tr>
<tr>
<td>Top 08 — Write a string to the display and to the listing</td>
</tr>
<tr>
<td>Comments</td>
</tr>
</tbody>
</table>
Conditional Text

Display or not display
Print or not print
  • in MS Word these are separate attributes
  • is that a good idea?

Look up “Hidden Text” in Word’s help index

Word only implements one class of conditional text
  • but it makes sense to have more
  • you can simulate having more than one class of conditional text using named styles

The Format > Style… Dialog in Word

Format → Style…

How would you do this?

Demo 4!
The Format > Style... > Modify Style sub-dialog

Recall the Model Pearl (interaction)

- Nested dialog boxes
  - radio buttons, check boxes, etc.
- Which is better? Should you have both?

The Format > Style... > Organizer sub-dialog
Word’s Format > Paragraph dialog box

Not all paragraph attributes are available in this dialog ex. bullets, borders... although they belong here

Widows and Orphans

Widow
stranded line at top of page

Orphan
stranded line at bottom of page
Word’s Format > Font… (ie. Character) dialog box

Style Templates

Store style definitions in a separate “template” or “style sheet” file

Use templates to keep styles consistent across multiple documents
  • each such document is linked to the template
  • when the template is changed, the appearance of every linked document
    • changes automatically? (optional in MS Word)
    • or do you have to request an update? (Keynote)

Another data model…
Every document is based on a template ("Normal" by default)
- apparently in the "~/Documents/Microsoft User Data/" folder...
  (instead of "~/Library/Application Support/Microsoft ... sigh)
- whose styles are copied to the document

To use a different base template
- use the "Attach" button in the Tools → Templates and Add-Ins… dialog box

To have Word reload the template’s styles every time you open the document
- check “Automatically Update Document Styles” in the Tools → Templates and Add-ins… dialog box

To cause a style change applied in a document to update its template definition
- Use the “Add to template” button in the Modify Styles dialog box, or change it directly in the template
“Invisible” (aka “non-printing”) characters

See Word’s Preferences > View dialog
Or, press ¶ from Word’s Home menu

Things That May Confuse You in MS Word

- Character attributes in paragraph styles
  - are a matter of convenience
  - when done, one set of character attributes is a property of the paragraph as a whole

- The Style Column
  - is visible only in Outline or Draft View, not Web Layout or Print Layout

- Some paragraph attributes
  - are in “auxiliary” dialog boxes instead of the paragraph dialog box even though they are paragraph attributes
  - ex. borders, bullets, numbering, shading

- Paragraph attributes
  - are “stored in” the ¶ at the end of each paragraph
  - are automatically copied to a new paragraph if you press RETURN
  - you can copy/paste this character to transfer its attributes to another paragraph
The Case For Styles

- It’s easier / quicker to change
  - the appearance of an existing document
  - determine the appearance of a conforming document
- They make it easier to achieve consistent appearance
  - within a document
  - using templates, across documents
- You can switch media much more easily

The Case Against

It takes longer to get started
Application Interface and Design

☑ In well-designed applications you can do everything via
  • menu items
  • dialog boxes opened by a menu item
  • a toolbar opened from a menu item
    — Why?
☑ Often there are other ways of doing things
  • typically faster but more obscure
    — Why?
☑ Are there other ways to
  • DEFINE named styles in Word?
  • APPLY named styles in Word?
☑ Explore the Styles pull-down in the Formatting toolbar
  • (The Poke pearl)

Styles & Style Templates (aka “Style Sheets”) Elsewhere

These ideas are applicable anywhere you have objects with attributes, though the term may not be used

Graphic Applications

Printing Huh? Think about this...

Web Pages

So look for them!
NEXT WEEK

- Pixel Graphics
- Have a digital photo ready for lab next week